Conectar-se

Esqueci minha senha

Estatísticas
Temos 31380 usuários registrados
O último usuário registrado atende pelo nome de eduardotn

Os nossos membros postaram um total de 38169 mensagens em 5768 assuntos

Lentidão com Load Ballance

Ir em baixo

Lentidão com Load Ballance

Mensagem por cshunter em Sab 15 Ago - 10:25

Bom dia galera, sou novo no  ramo e configurei uma rb750GL com duas internets com links iguais, está funcionando, mas de vez em quando fica lento. Minha duvida, se sempre tem uma internet como prioridade, se esta ficar lenta por motivo dela mesma tem como o aparelho mudar para a outra automatico ou fazer algum script para isso. nos testes que fiz ele só muda quando um link cai e não quando fica lento.  Desde já agradeço a ajuda.


Vejam como esta a configuração, fiz uma adapatação do codigo que era para 4 links para 2.


Código:
/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2
Código:
/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
Código:
add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
Código:
add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local
Código:
add chain=prerouting dst-address-type=!local in-interface=Local
per-connection-classifier=both-addresses-and-ports:4/0
action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add
 chain=prerouting dst-address-type=!local in-interface=Local
per-connection-classifier=both-addresses-and-ports:4/1
action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
Código:
add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2
Código:
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping
Código:
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping
Código:
/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade
Código:
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=221.132.112.8,8.8.8.8

cshunter
Baby
Baby

Mensagens : 1
Pontos : 3
Reputação : 0
Data de inscrição : 12/08/2015
Idade : 42
Localização Localização : itabaiana SE

Voltar ao Topo Ir em baixo

Re: Lentidão com Load Ballance

Mensagem por wilbeme em Seg 5 Jun - 11:45

CÓDIGO:
Código:
add chain=prerouting dst-address-type=!local in-interface=Local 
per-connection-classifier=both-addresses-and-ports:2/0 
action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add
 chain=prerouting dst-address-type=!local in-interface=Local 
per-connection-classifier=both-addresses-and-ports:2/1 
action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

wilbeme
Baby
Baby

Mensagens : 10
Pontos : 12
Reputação : 0
Data de inscrição : 29/09/2014
Idade : 62
Localização Localização : Fortaleza

Voltar ao Topo Ir em baixo

Re: Lentidão com Load Ballance

Mensagem por claudinhohw Network em Ter 6 Jun - 11:45

cshunter escreveu:Bom dia galera, sou novo no  ramo e configurei uma rb750GL com duas internets com links iguais, está funcionando, mas de vez em quando fica lento. Minha duvida, se sempre tem uma internet como prioridade, se esta ficar lenta por motivo dela mesma tem como o aparelho mudar para a outra automatico ou fazer algum script para isso. nos testes que fiz ele só muda quando um link cai e não quando fica lento.  Desde já agradeço a ajuda.


Vejam como esta a configuração, fiz uma adapatação do codigo que era para 4 links para 2.


Código:
/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2
Código:
/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
Código:
add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
Código:
add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local
Código:
add chain=prerouting dst-address-type=!local in-interface=Local
per-connection-classifier=both-addresses-and-ports:4/0
action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add
 chain=prerouting dst-address-type=!local in-interface=Local
per-connection-classifier=both-addresses-and-ports:4/1
action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
Código:
add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2
Código:
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping
Código:
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping
Código:
/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade
Código:
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=221.132.112.8,8.8.8.8
sim se vc usa 2 ou mais ADSL ou links de internet e um fica lentos todos vão ficar pq o balance não sabe que um esta ruim ele vai balancear de acordo com o as marcações de links que vc fez.

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik
avatar
claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2808
Pontos : 3465
Reputação : 598
Data de inscrição : 28/08/2010
Idade : 34
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: Lentidão com Load Ballance

Mensagem por Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum